
Chapter 24:  Creating Reports and Extracting Data 
SEER*DMS includes an integrated reporting and extract module that enables you to run pre-
defined system reports and create standard extracts.  You may create external queries to generate 
custom reports and extracts.  Tools such as Perl, Microsoft Access, Crystal Reports, SAS, 
JWorkbench, and SEER*Stat can be used to generate reports or analyze data extracted from the 
SEER*DMS database. 

Although external applications may be used to access both the live database and the data 
warehouse, it is strongly recommended that you access the data warehouse unless the analysis 
absolutely requires data from the live database.  Complex or inefficient queries to the live database 
may affect system performance and affect interaction with the system by registry staff.  Registry 
staff with the appropriate system permissions can read and write data in the live database via the 
SEER*DMS application.  Write-access to the live database through external applications is 
controlled by Oracle system permissions and should only be granted to registry system 
administrators.  See Chapter 2:  Records and Patient Sets for descriptions of the live database and 
data warehouse.   

In this chapter, you’ll learn about 

• Creating Reports 

• Data Extracts and Submissions 

• Finding a Report or Extract 

• Organizing your Reports 

• Running a Report or Extract 

• Viewing Output of Reports 

• Downloading an Extract Data File 

• Searching the Worklist for Report and Extract Tasks 

• Sending Report Output to another User 

• Viewing the SQL for a SEER*DMS Report 

Creating Reports 

Three methods can be used to create a report using SEER*DMS data: 

• Generate one of the SEER*DMS Reports listed in the Report Manager.  These include reports 
which summarize workflow activities, track imported data, list data which fail edits, and 
provide quality control information.   

• Click a Print button or select a Print menu item in the system.   Print buttons, links, and 
menu items are integrated throughout the system.  Instructions for generating these 
reports are provided in the chapters for the related activities.  

• Create a custom, external report using any of a variety of software packages to access the 
SEER*DMS data directly.   Reporting tools such as Microsoft Access, Crystal Reports, SAS, 
etc., can be used to generate reports using data in the live SEER*DMS database or the data 
warehouse.  Sample reports and SQL are available on the SEER*DMS Web Portal 
(http://seer.cancer.gov/seerdms/portal).  The development and maintenance of external 
reports are the responsibility of registry staff.  Contact your registry’s system administrator 
for information regarding the external reports available at your registry. 

Revisions and additions to reports within SEER*DMS are under the control of the Change Control 
Board.  The Documentation section of the SEER*DMS Web Portal includes a description of each 
system report and extract.  This documentation describes reports in the SEER*DMS Report 
Manager as well as reports that are integrated as print mechanisms throughout SEER*DMS.   
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Data Extracts and Submissions 

Standard data extracts, such as the SEER submission file, have been integrated into the reporting 
module of SEER*DMS.  In addition, Perl extract scripts which use imbedded SQL queries have been 
provided as examples of external scripts for creating custom extracts.  Ad-hoc extracts can easily 
be produced using any tool or programming language which can access Oracle or ODBC.  These 
include Crystal Reports, Access, Perl, Python, SAS, and many others. 

The SEER*DMS database and data warehouse can be accessed from PC applications.  To access the 
database from Windows-based software, drivers must be installed on your PC to enable 
connectivity with the Oracle databases.  For example, you may install ODBC drivers to enable 
access to the databases using Crystal Reports or Microsoft Access.  Instructions and files required 
to install ODBC drivers are provided on the SEER*DMS Web Portal.  Other applications, such as 
SAS, may require additional components provided by the vendor. 

The SEER*Stat software can be used to generate reports and to generate incidence, survival, and 
prevalence statistics.  Once you extract data to a text file, you may use the SEER*Prep software to 
create a SEER*Stat database from the data stored in the extract file.   

Please contact your registry’s system administrator for specific instructions on creating or using 
external extract programs. 

Finding a Report or Extract 

System permissions: reports is required to access the Report Manager.  Certain reports also 
require reports_management; extracts are only listed if the user also has the extract_create 
permission.  A report’s permission is displayed on its Report Specifications page. 

To find a SEER*DMS Report or Extract: 

1. Select View > Reports.   

a. Reports and extracts are organized into categories.  These include a category for 
reports that you used recently, pre-defined categories, and categories that you 
create.  When you access the Report Manager, SEER*DMS will display the category 
that you viewed when you last visited the Report Manager.  If this is your first time 
accessing reports, all reports and extracts will be displayed.   

b. Reports and extracts are listed by ID.  Report IDs have an “RPT” prefix; extract IDs 
use an “EXT” prefix.  Registry-specific reports include a 2-character registry code 
following an RPT prefix (RPT-DT013A, for example).   

2. To view a list of reports in a category, click the category name displayed on the left.  

3. To search for a report by ID, title, or description, type text in the box labeled Type to 
Search and press the Enter key.   

Organizing your Reports 

System permissions: reports 

The report categories are defined by tags associated with the reports.  A report’s categories or 
“tags” are listed next to its title in the Report Manager.  You may create new categories by adding 
tags.  
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To organize reports into your own categories: 

1. Click View > Reports.  

2. Use the search box or category links to find the report (see the Finding a Report or Extract 
section of this chapter). 

3. Hover your cursor over a report to select it.  Click the Edit Tags link shown for the report. 

 

4. To create a new category, click Specify New Tag. 

5. To add the report to a category that you created previously, click the appropriate tag in 
the Add Tag list.  You may not add a report to a pre-defined category. 

6. To remove a report from a category, click the category’s tag in the Remove Tag list. 

Running a Report or Extract 

System permissions: reports is required to access the Report and Extract Manager.  Certain reports 
also require reports_management; extracts are only listed if the user also has the extract_create 
permission.  A report’s permission is displayed on its Report Specifications page. 

To run a Standard Report or Extract in SEER*DMS: 

1. Click View > Reports.  

2. Use the search box or category links to find the report (see the Finding a Report or Extract 
section of this chapter). 

3. Hover your cursor over a report to select it.  Click anywhere in the highlighted area to 
open the report template. 
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4. You will use the Report Specifications page to define the report’s output format and set 
parameters.   

a. A detailed description of the report parameters is included in the Description section 
of the page.  If you would like to view the SQL of the report, refer to the instructions 
in the Viewing the SQL for a SEER*DMS Report section of this chapter.  

b. Specifications used previously are available in the Previous Parameters section of 
the page.  Click a row to set all specifications to the same values used in a previous 
run.   

5. If you are executing a report: 

c. Edit the Title as necessary.  This is the first title line shown in the report.  Many 
reports include sub-titles which are often used to display parameter settings.  You 
may wish to run and review the report to determine the best title.   

d. Set the Output Format to PDF or CSV (Comma Separated Values) based on the 
following considerations.   

i. PDF:   Many of the SEER*DMS reports were designed to be viewed or printed as 
PDF files.  Forms and record printouts should be output to PDF and may not 
display properly in CSV format. 

ii. CSV:  Many of the reports are tabular and can be exported to Comma Separated 
Values (CSV) format.  You may open a CSV file in Excel or in a text editor.  The 
CSV format is recommended if you wish to copy Patient Set or Record IDs from 
the report and paste them into the ID Lookup (see Chapter 20:  Searching for 
Records and Patients). Tables that do not have consistent rows and columns may 
not export correctly to CSV.   

e. Use the parameters to customize the report.  Typically, parameters are used to specify 
the cohort or define the sort order.   

i. If a parameter’s label is in bold text, it is required.   

ii. A blank setting for an optional parameter implies “all possible values” for that 
field.    

iii. Some reports have the potential to request large volumes of data from the 
database.  To prevent a report from affecting the response time for other users, 
SEER*DMS terminates report queries that exceed the time limit or generate a 
large result set.  The thresholds are defined by the reporting.time-out.minutes 
and reporting.max.rows configuration settings.  SEER*DMS enforces the value for 
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maximum rows set in the configuration settings unless a report-specific value is 
specified in the report’s XML file.  If a report exceeds the time or row limit, the 
Report Output task will display an error message.  You will then have the 
opportunity to select new parameters to reduce the amount of output. 

6. If you are creating an extract data file: 

a. Edit the Title as appropriate.  This title will be associated with the Report Output task 
and can be used to find the task in the worklist.   

b. Set the extract parameters to meet your needs. If a parameter’s label is in bold text, 
it is required.  A blank setting for an optional parameter implies “all possible values”.  
(Note:  the filename entered here will be used as the default name when you 
download the extract file.) 

7. Run the report or extract by clicking the appropriate button: 

a. Run – queries the database and creates the report as you wait.  (This option is not 
available for extracts.)  If this process is able to complete within a time limit specified 
in the SEER*DMS configuration, the Report Output task will open automatically.  If the 
time limit is exceeded, the report will automatically be run offline and the Report 
Output task will be available in the worklist when the task completes. 

b. Run Offline – creates an automated, Run Report workflow task.  You will be returned 
to the Report Manager.    

8. To open the report, follow the steps in the Viewing Output of Reports section of this 
chapter.  To download the extract data file, follow the steps in the Downloading an Extract 
Data File section of this chapter. 

In order to protect the system from a slowdown caused by a large query, SEER*DMS limits the 
number of report and extract tasks that are processed simultaneously.  Additional report and 
extract tasks are queued and are executed when others complete.   

Viewing Output of Reports 

Requires system permission:  reports (certain reports also require reports_management) 

An automated Run Report worklist task is created when a report is executed.  When the report is 
successfully generated, a manual Report Output task is created and assigned to the user who 
submitted the report.  If the report was executed using the Run command, this Report Output task 
opens automatically (proceed to step 2 in the instructions below).  If a Run Report task fails, a 
System Failure task is created. 

To view the output of a report that you submitted: 

1. To view the output from a report that ran offline: 

a. Click View > Home or click SEER*DMS in the top banner to return to the home page. 

b. Click Report Output in the My Tasks section of your worklist summary.  If this link is 
not shown, the report may have failed or may still be running (see the instructions 
below for Searching the Worklist for Report and Extract Tasks). 

c. If you are searching for a recently generated report, click the Task column header to 
reverse the sort order of the list.  This will bring the most recently run report to the 
top of the list. (The oldest worklist tasks are shown at the top of the list when you first 
go to the worklist.) 
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d. To search for a report by title, enter a full or partial title into the Information filter 
and click Apply. 

e. If the task is not displayed in the list, the report may have failed or may still be 
running (see the instructions for Searching the Worklist for Report and Extract Tasks). 

f. Click on the Task ID to open the Report Output task. 

2. Due to memory limitations in the reporting engine and the impact of exhaustive queries on 
system response time, SEER*DMS must restrict the execution time and number of result 
rows generated by each report.  The thresholds are defined by the reporting.time-
out.minutes and reporting.max.rows configuration settings.  If either limit is exceeded, an 
error message will be displayed.  Click Edit Specifications to specify parameters that 
reduce the number of records, and re-run the report. 

3. Click View.  You will be prompted to Open or Save the report.  Click Open.  If the output 
format is PDF, Open the report with Adobe Acrobat.  If the output format is CSV, open the 
report with Excel.  

a. Use the Adobe or Excel controls to print or save this report. 

b. Close the Adobe or Excel window. 

4. If you need to correct parameter values or titles, submit a new report: 

a. Click Edit Specifications. 

b. You may make modifications to the Title, Output Format, and Parameter fields. 

c. Click Run or Run Offline.   A new task will be submitted.  The existing task will 
remain in the worklist until it is removed.  You will be returned to the worklist. 

5. If you will not need to access this Report Output task again, you should remove the task 
from the worklist to prevent unnecessary clutter.  Click Remove to permanently delete 
this task and the PDF or CSV file from the worklist.  If you may need to access this Report 
Output task again, click Close to save and return to the worklist. 

Downloading an Extract Data File 

Requires system permission:  reports and extract_create 

An automated Run Extract Report task is created when a SEER*DMS extract is executed.  When 
the task completes, an email is sent to the user who initiated the task and a Report Output task is 
created and assigned to the user.  If a Run Extract Report task fails, a System Failure task is 
created. 

To download an extract data file: 

1. Open the Report Output task for the extract: 

a. Click View > Home or click SEER*DMS in the top banner to return to the home page. 

b. Click Report Output in the My Tasks section of your worklist summary.  If this link is 
not shown, the extract task may have failed or may still be running (see the 
instructions below for Searching the Worklist for Report and Extract Tasks). 

c. If you are searching for a recently generated extract, click the Task column header to 
reverse the sort order.  This will bring the most recently run report or extract to the 
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top of the list. (The oldest tasks are shown at the top when you first enter the 
worklist.) 

d. To search for an extract by its title, enter a full or partial title into the Information 
filter and click Apply. 

e. If the task is not displayed in the list, the task may have failed or may still be running 
(see the instructions below for Searching the Worklist for Report and Extract Tasks). 

f. Click the Task ID to open the Report Output task. 

2. Review the following items that are provided in the Report Output task: 

a. Num Records – the number of records included in the extract data file.  If this value 
is zero, review the parameters that were specified to determine if an error was made. 

b. Filename – the filename field in the Parameters section contains the text that you 
entered when you executed the extract.  Depending on your browser, you may or may 
not be prompted for a filename.  If not, the file will be saved to your browser’s 
Download folder with this name. 

c. Parameters – verify that the correct parameters were used to create the extract. 

3. If you need to correct parameter values, submit a new extract:  

a. Click Edit Specifications. 

b. You may make modifications to the Title and Parameter fields. 

c. Click Run Offline.   A new task will be submitted.  The existing task will remain in the 
worklist until it is removed.  You will be returned to the worklist. 

4. To download the extract data file: 

a. Tips for managing downloads in Firefox: 

i. Typically, the file will be downloaded to a folder that is defined as the “Downloads” 
folder in Firefox.  In the Firefox menus, go to Tools > Options and select the 
Downloads tab.  Verify that the downloaded data will be stored in an appropriate 
location.  Change this location, if necessary.  Pease refer to the Firefox user’s 
manual for more specific instructions. 

ii. At any time, you may access your download folder by selecting Tools > 
Downloads from the Firefox menus. 

b. Click Download on the Report Output Task page.  Depending on browser settings and 
version, the file may be saved to your download folder automatically or you may be 
prompted to Open or Save the file.  If prompted, click Save to Disk.  If you are not 
prompted to select a location, the file will be saved in the folder that is defined as the 
“Downloads” folder in Firefox.  

5. If you will not need to access this Report Output task again, you should remove the task 
from the worklist to prevent unnecessary clutter.  Click Remove to permanently delete 
this task from the worklist and delete the data file from the server.  If you may need to 
access this Report Output task again, click Close to save and return to the worklist. 
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Searching the Worklist for Report and Extract Tasks 

Requires system permission:  reports 

Each submitted report or extract task will appear in the worklist as a Run Report, Run Extract 
Report, Report Output, or System Failure task.  When the task is initiated, SEER*DMS creates 
either a Run Report or Run Export Report task.  The results for both are made available in a Report 
Output task which is assigned to the user who initiated the task.   If the task fails, an unassigned 
System Failure task will be initiated.  SEER*DMS users with the system_administration permission 
can access and review System Failure tasks. 

To search the worklist for output from report or extract tasks:  

1. Click View > Worklist or click the Worklist link on the home page. 

2. If you are only interested in reports and extracts that you submitted, enter your user 
name in the User(s) filter.   

3. Place a check in the Show Unassigned filter. 

4. Select Report Output in the Type(s) filter. 

5. Click Apply. 

If a report or extract that you were expecting is not displayed, it may still be running (change the 
filter to include “Run Report” or “Run Report Extract” tasks in the search). 

Sending Report Output to another User 

Requires system permission:  worklist_task_reassignment 

Typically, you should distribute reports and extract data by saving the files to disk or providing 
printed copies of reports.  However, SEER*DMS does allow you to reroute Report Output tasks to 
other users via the same mechanism used to reroute any worklist task.   Users must have the 
appropriate permissions to access the output tasks. 

To reroute a Report Output task to another user: 

1. Select View > Home or click SEER*DMS in the top banner to return to the home page. 

2. Click Report Output in the My Tasks section of the worklist summary.  If this link is not 
shown, the report may have failed or may still be running. 

3. If you are searching for a recently generated report, click the Task column header to 
reverse the sort order of the list.  This will bring the most recently run report to the top of 
the list. (The oldest tasks are shown at the top when you first enter the worklist.) 

4. To search for a report, enter a full or partial Report ID or title into the Information filter.  
Click Apply. 

5. Check the box to the left of the Task ID. 

6. Click Modify. 

7. Set the Action to Re-route to User. 

8. Select a user name from the pull-down list.  Only system users with permission to view the 
report or open the extract will be listed.  To view report output, the user must have either 
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the reports or reports_management permission; extract_create is required to access 
output tasks related to extracts. 

9. Click OK. 

Viewing the SQL for a SEER*DMS Report 

Requires system permission:  system_administration 

XML files containing source code for system reports are included in the System Files segment of the 
System Administration page.  If a report is implemented in SQL, the query will be included in its 
System File.   

To view a SEER*DMS Report’s SQL: 

1. Click System > Administration.  The current server log will be shown when you first 
enter the page. 

2. Select System Files from the Name drop-down list. 

3. Select the appropriate XML file from the Reports section of the Files drop-down list.  
Report filenames begin with the report ID (rpt064A.patient.edit.error.summary.cfg.xml, 
for example). 

4. Search for the “query” XML tag.  If the query type is SQL, the SQL will be displayed within 
the XML file.  If the query type is Java, the source code will not be displayed.   

5. SQL for system reports include non-SQL code to implemented report parameters.  Refer to 
the Sample SQL section of the SEER*DMS Web Portal for instructions in modifying the SQL 
so that it can be used in external applications like SQL Workbench. 
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